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LabVIEW FPGA @ CERN 2023

POWERED BY

- Unofficial
- For fun
- Share knowledge




About the workshops

Minimize theory
Maximize practice
Some fun examples




LabVIEW
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NI : part of Emerson

Leader in data acquisition technology with
innovative modular instruments and
LabVIEW graphical programming software

Ritu Favre / CEO

. Corporate headquarters in Austin, TX
. Offices in nearly 50 countries

. 35,000+ companies served annually
. More than 1,000 products

. Approx. 7,100 employees

. 600 Alliance Partners

. Part of Emerson Electric Co. this year

FORTUNE"

100 BEST
COMPANIES

10 WORK FOR




Diversity of applications

AEROSPACE, DEFENSE, &
GOVERNMENT

ELECTRONICS ENERGY ACADEMIC & RESEARCH




SpaceX

Falcon rocket launch pad software




Commercial nuclear fusion power




LabVIEW on different hardware

Applications

PXI and Modular
Instruments

Desktops, Laptops,
and Mobile

Ty
£
| = :
ESsShas
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NI CompactDAQ NI CompactRIO

Hardware




Projects based on NI @ CERN

- LHC collimators real-time control system

Axes positioning accuracy few um
Axes motion synchronization below 1 ms
Response delay to a digital start trigger 100 ps

Position sensors RT survey frequency

Reliability Very high




* LHC collimators real-time control system

Layout 120 systems Architecture

LHC PROJECT 1 Machine Timing Distribuion |

Collimator Supervisory System
{one or two per LHC point)

Synchronisation control

Underground, low radiation area

Local Ethernet Segment
|
| “ |
Motor Drive Control Position Readout and Environment Survey
Survev

e
| Beam

| Interlock
LHC tunnel

e Maquette 3D a faire
Magquette 3D en cours
— Maquette 3D en standard

&)
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Projects based on NI @ CERN

» Measurement setup for characterization of the radiation
hardness of cryogenic bypass diodes for the LHC-HL

Power supplies for heaters

PXI| system components:
-7 x DMM 4081
- DAQ M-series 6251

- GPIB

[ LHC by-pass diodes
- Ethernet

HV power supply — 3kV max

[ Mu-metal shield (against magnetic

Discharge circuit ] field)
Capacitor bank 13,3 mF, 1500V ] [ Feedthough 16kA
L [ Cryostat
LA A R
MWy
~ 30m |

Measurement rack Measurement setup assembly and closed cryostat




CERN LabVIEW support

Website: cern.ch/labview
E-mail: labview.support@cern.ch




Why LabVIEW?

Same concepts as in traditional
languages (data types, loops, event
handling, recursion and OOP)

Data flow (execution is data-driven, not
determined by sequential lines of text)
Automatic parallelism
Automatic data synchronisation

Intuitive

Easy to debug

NI hardware integration
Combines with other languages

:

>
Amplitude and
Level
Measurements

b

pocex( b Signals
RMS
8 N
Spectral
M N
AG34401
&’ JENES) Signals
e Power Spectrun
Multiple Points ¥
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d »

Filter

> Signal

Filtered Signal




B. Project Explorer

Project Explorer Window
Files Types
Project Folders




Project Explorer

_ [ EPS-FPGA-demoS.lvproj - Project .. — O
o See the hlerarChy File Edit View Project Operate Tools Window Help
. . . [tems Files
’ Organlse prOJeCt flleS = [ Project: EPS-FPGA-demaS.lvproj PC
- My Cormputer <
L4 Deploy flleS tO targets E}[?LJ rfrF"rcuf_-LE:It [:DCUmEHtEtIDH
. Manage code for builc LR
t_ =8 ngyELo-FpriA-pgga?;DEJ?E.&J1.zj < ARM
Op IonS 7 e a:s- Tr':e c-an ESOUFCES
; g EpslnTTarg:t(mgq ryRIO-1900) < FPGA
- Executables, installers, ) £PS-CPU-demosa
and le .I:IIeS - e Build Specifications
- Integrate with source
code control providers




Project Explorer

s Y

Xilinx Zyng 7010

[ EPS-FPGA-demoS.lvproj - Project .. — O
File Edit View Project Operate Tools Window Help
ltems | Files

Eg. Project: EP5-FPGA-demod.vpraoj

L

E} H My Computer <

£ I, myRIO-FPGA-Adriaan (17222.112) <
- B8 Chassis (myRIO-1900)

i [ Project Docurnentation
- [l Channel-wire-example.vi
:l-; Build Specifications

> i® Real-Time Scan Resources
- & FPGA Target (RIO0, myRIO-1900) <

- |mll, EP5-CPU-demoSvi

:l-; Build Specifications

PC

ARM
FPGA




Connect to myRIO

Don’t have the myRIO connected yet
Power up the myRIO

Wait until the Status LED is off
Connect the myRIO to your PC

e




Start LabVIEW ‘
| 7 mommo-son

Serial Number: 030B8ABO

SRR P C IP Address: 172.22.11.2

Options

) Launch the Getting Started Wizard
myR|O DD GotoLabVIEW 2019 5P1 Go to LabVIEW

)) Launch the I/0 Monitor
)) Configure myRIO

) Do Nothing




Project

. B Labview

Blank Project

File Operate Tools Help

B> LabVIEW 203Z myRIO Toolkit EE N

AESEEEN.  pC

Al
Blank Project FPGAT1 Ivproj
LabVIEW Real-Time Control on CompactRIO (RIO Scan Interface) TemperatureContro lvproj
Scan Engine lvproj
myR | O PattemRecog Ivproj
TestLED lvproj
AccDetector lvproj

First-F-Proj lvproj

Set Up and Explore Do a Project Get Support

Set up and leam how to use myRIO! See examples and get inspired! Get answers to your questions!

B LabVIEW News |




New target

[ EPS-FPGA-demoS Ivproj - Project .. = O
File Edit View Project Operate Tools Window Help

ltems | Files

= [&) Project EPS-FPGA-demo5lvpro] < nght click Pr0jeCt
\\\\ PC I:?}E?EJMyPEDDJr:ftuszlumentatmn Choose NeW _>
- ml Channel-wire-example.vi 1
++. Build S'::lv.=.-r:iFir:Eltiu:uns.FI targets and deVIceS

= ., myRIO-FPGA-Adriaan (172.22.11.2)
E- &8 Chassis (myRIO-1900)
> [# Real-Tirme Scan Resources
3] {5} FPGA Target (RIOD, myRIO-1300)
- ml, EPS-CPU-demoSwi
+_ Build Specifications




Select myRIO

File Edit View Project Operate Tools Window Help

Items Files

[ bg. Project: Untitled Project 1 ]
=3 N_ My Computer B Add Targets and Devices on Untitled Project 1
L. Build Specifications
Targets and Devices

(@) Existing target or device
@ Discover an existing target(s) or device(s)
O Specify a target or device by IP address
() New target or device

ATEEERRNN

PC

+H) ELVISRIO
+H) Ethernet RIO
EHD myRIO

8 NI-myRIO-1900-Adriaan
#4) Real-Time CompactDAQ
+H2) Real-Time CompactRIO
+12) Real-Time Desktop
+{) Real-Time PXI
++2) Real-Time Single-Board RIO
44 roboRIO
#4) Touch Panel
4 Windows CompactRIO

< >
[ Reduce discovery timeout

Refresh Ok Cancel Help

}‘ Targets and Devices ~

Open myRIO with +
Select NI myRIO
OK




repare myRIO

AESEEEN.  pC

m Untitled Project 1 * - Project Explorer -

m}

File Edit View Project Operate Tools Window

Items Files

X
Help

@ Real-Time Scan Resources

&} FPGA Target (RIOO, myRIO-1900)

i [ Onboard I/O

+ [ ConnectorA

= [ ConnectorB

= [ Analog
ConnectorB/AO0

ConnectorB/AO1

ConnectorB/AI0

ConnectorB/Al1

ConnectorB/AI2

ConnectorB/AI3

.\:\
s}
o
=]

R A

ConnectorB/DIO0
ConnectorB/DIO1
ConnectorB/DIO2
ConnectorB/DIO3
ConnectorB/DIO4
ConnectorB/DIOS5
ConnectorB/DIO6
ConnectorB/DIO7
ConnectorB/DIO7:0
@ DIO15:8

B Connecio

G Audio

- B 40 MHz Onboard Clock
b @) IP Builder

- ‘# Build Specifications
-, Build Specifications

Close tabs:

Onboard I/O
Connector A
Connector B DIO15:8
Connector C

Audio




NI myRIO Product Overview: Front View

"ZNATIONAL
) INSTRUMENTS

XILINX Zyng SoC



What Is Zynq?

Traditiondl Ihqli[glnentatlon

ANSIS;
Processor

Analogue Input

Analogue Output

Digital I/O

Custom /O




Why Zyng Matters in Education

Smaller Size, Lower Power

*667 MHz Dual-Core ARM Cortex-
A9 Processor

*Artix-7 FPGA, 28k logic cells

16 DMA Channels

*92 Billion calculations per second



Why Zynq Really Matters in Education

Leading Industry
Grade Technology

The same technology is used in
the modular I/O Compact RIO
systems



C. Parts of a VI

Front Panel
Block Diagram
lcon

Connector Pane




Parts of a VI

VIs have 3 main components:

| = L =iz, |)

- siiP=] |} Icon/Connector pane

-

m add&sub.vi Front Panel

File Edit View Project Operate Tools Window Help
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Parts of a VI — Front Panel

ile Edit View Project Operate Tools Win

Ele Edit View Project O Tools Window Hel
You bUIId the [ ]2 OITiHISDtAppIicationFont |v||g,;,.||.;;. [ [e% |[+] search oy ”@|%

front panel with ]
controls (inputs)
and indicators @
(outputs).




Parts of a VI — Block Diagram

==

Front panel s
ob J ects (5] 0] [0 e oepepnconfore [+ o [ [ [ s 2 [2)
appear as

terminals on
the block

diagram.

A




Parts of a VI — Ilcon/Connector Pane

=13

1

Icons and connector panes are necessary to use
a VI as a subVI.

A subVl is a VI that appears on the block diagram of
another VI.

A subVl is similar to a subroutine or function in a text-
based programming language.




Show — off (2)

Figures




D. Front Panel
Controls and Indicators

Object Styles

Object Types
Boolean
Numeric
String




Front Panel

o>

&

@

15pt Application Font |+

o
ol

g™

¥ Search

& Using Temperature.vi Front Panel
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Controls and Indicators

Controls Indicators
Input devices - Output devices
Knobs, buttons, - Graphs, LEDs
slides Display data the block
Supply data to the diagram acquires or
block diagram generates

Temperature graph

215+

-
[}
5 205-
f
o 20-
© 19.5-
Speed 19-
4 5 6 h—
3\ N ’ ,7 B 1
2
9

Temperat

1 1 1 i 1
0.02 0.04 0.06 0.08 0.1
Time




Front Panel Object Styles

Modern

Waveform Graph Sine with Uniform Noise l

16~

1-

-8 0:5=
=
= O
E
< -05-
-1-
'1-5-| 1 1 1 1
0 0.025 0.05 0.075 0.1
Time
Path Wrong

I'% [Users/adriaan.../LV-FPGA-class

=

OK Cancel

STOP

Silver

[ Sine with Uniform Noise |/ ]

Waveform Graph

16
1-
o 05-
2
g7
< -05-
-1-
-15-, 1 1 1 1 1
0 0.02 0.04 0.06 0.08 041
Time
File Path irong

["}‘ /Users/adriaanr/Documents/LV-FPGA-class | ] ©

res

['».j oK ] [m Cancel




Numeric Controls and Indicators

The numeric data in a control or indicator can represent
numbers of various types, such as integer or floating-
point.

Input

/,[ﬁ |n—|} B numeric

control

Increment/Decrement
buttons

Cutput

wnere — 0]

indicator




Boolean Controls and Indicators

- The Boolean data type represents data that has only
two options, such as True/False or On/Off.

« Use Boolean controls and indicators to enter and
display Boolean (TRUE/FALSE) values.

- Boolean objects simulate switches, push buttons and
LEDs.

Push Button LED

Boolean = A Boolean
control ) @ Qz" — indicator




Strings

« The string data type is a sequence of ASCII characters.
« Use string controls to receive text from the user.
« Use string indicators to display text to the user.

String Control Table

Receive text from user
here,

] Headingl Heading2 &
A ‘ ‘

Ohokn =l kg
M om Oy m

String Indicator
Display text to the =

IJ] Ad

user here, Add a
scrollbar if necessary.




E. Block Diagram

Terminals
Nodes
Wires
Help




Block Diagram
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Block Diagram

Block diagram items:

Terminals
Constants

Nodes

Functions
SubVIs
Structures

Wires
Free labels

Mumber of Measurements

—m

|

Thermometer (Demo).wi

Temperature Chart

i

Delay Multiplier

S

5|
[ F ey
DE

Wait Until Mext ms Multiple

i

Stop Button

.




Terminals

_ Area of a Triangle
Height {crm)
[=] A
(=119 | Area (em*™2)
; —
e e D
]
—1) A
v
Determines the area of a triangle.
=---- Base -
Baze (cm)

Area (cm™2)
FDEL |

F

Triangular Multiplier
Height (cm)

[DBLH———




Terminals for Front Panel Objects

« Terminals are:

- Entry and exit ports that exchange
Information between the front panel and
block diagram

- Analogous to parameters in text-based
programming languages
- Double-click a terminal to locate the Input

Input

corresponding front panel object E oo




View Terminals as Ilcons

String
T E-F-H . .
« By default, View as Icon E Visible Items >
. Find Control
option enabled.
. Make Type Def.
* Deselect View as Icon for a e Contra
more Compact VleW Change to Indicator
Change to Constant
MNumeric Mumeric Boolean String Description and Tip..

String Palette 3
Create 3
4
4

: Data Operations
Mumeric
Advanced

Mumeric '
= Iy
= bt =

Properties




Nodes

Nodes are objects on the block diagram that
have inputs and/or outputs and perform
operations when a VI runs.

Base (cm)

Area (cm®2)
L | 2>t

Triangular Multiplier
Height (crm) 05
=




Function Nodes %

« Functions are:

Fundamental operating elements of LabVIEW.

Do not have front panels or block diagrams, but do have
connector panes.

Has a pale yellow background on its icon.
« Double-clicking a function only selects the function.
« Functions do not open like VIs and subViIs.




S u bV I N O d e S '-.-'-.-'riE To Spreadshest File, vi

« SubVls:

Are VIls that you use on the block diagram of another
VI.

Have front panels and block diagrams.

Use the icon from the upper-right corner of the front

panel as the icon that appears when you place the
subVI on a block diagram.

« When you double-click a subVlI, the front panel
and block diagram open.

« Any VI has the potential to be used as a subVI.




Express Vis T
t EXpress VIS Stton
- Are a special type of subVI. o

- Require minimal wiring because you
configure them with GUI dialog boxes.

- Save each configuration as a subVI.

« |cons for Express Vs appear on the

block diagram as icons surrounded by
a blue field.




Structures

« Structures in LabVIEW have the
form of fes.

..,.,.,a,.,a,a,'é = | [I:I] Timeout v#l—

Source
Type

- Other nodes (functions, subVls,
more structures) can be inserted into
the frames.




Wires

«  Wires transfer data between block diagram
objects.

«  Wires are different colors, styles, and
thicknesses, depending on their data types.

Floating-point Integer String Boolean

Scalar — —  mmmmmmmne

1-D Array S — Gecenacacd oo,

2-D Array — — RARARRRRAS S
« Abroken wire appears as a dashed o e

black line with a red X in the middle.




Constants

« Constants are the source of values just as
control terminals, but their value is fixed in the
code.

« You can create a constant of each data type.

[F] ILab‘u"IE'u.l".f::cbursel




Free labels

« Afree labelis a label (a text box) not attached to any object.

Free labels can be put on the front panel or block diagram. They are
created by double-clicking on empty space in the window.

« They can serve as comments or instructions to the user of the
application.

;rhls ts;8 fre Jabelon the This is the default formatting
ront panel. You can change

the formatting of the text of a block diagram free label.

and background color as well.




Context Help

Displays basic information about
wires and nodes when you move
the cursor over an object.

« Can be shown or hidden in the
following ways:

- Select Help»Show Context Help
from the LabVIEW menu.

« Press <Ctrl-H>.

-« Click the following button on the
toolbar:

Context Help

=]

Data type of wire
E# (long [32-bit integer (-2147483648 to 2147483647]])

EIBI7] « | r

-

Context Help

Read From Spreadsheet File.i
format (3.3

file path (dialog if ernphy)
number of rows (all:-1)

newy file path (Mot & Path ...
all rovus
mmatk after read (chars)

transpose {no:Fy

Reads a specified number of lines or rows from a nurmeric text file
beginning at a specified character offset and converts the data to a 20,
double-precision array of numbers, strings, or integers, You must manually
selectthe polyrorphic instance you want to use,

Detailed help

[F[a[?] -

»




LabVIEW Help

» Contains detailed descriptions and
Instructions for most palettes, menus,

tools, VIs, and functions.

Contents| Index | Search| Favorites

« Can be accessed by: o

- Selecting Help»
LabVIEW Help from the menu.

) @ LabVIEW Documentation Resources
@ Getting Started with LabVIEW

. . .
@ Fundamentals

- Clicking the Detailed hel
@ Property and Method Reference
i @ Taking Measurements

@ Cortiolling Instruments

link In the i
Context Help window.

- Right-clicking an object
and selecting Help from

the shortcut menu.

NATIONAL
INSTRUMENTS"

LabVIEW™ Help
June 2011, 371361H-01

This help system includes information about LabVIEW
prograrnming concepts, step-by-step instructions for
using LabVIEW, and reference information about
LabVIEW Wls, functions, palettes, menus, and tools,

To navigate this help system, use the Contents, Index,
and Search tabs to the left of this window.

After you install a LabVIEW add-on such as a toolkit,
module, or driver, the documentation for that add-on
appears in the Labl/ZEW Help or appears in a separate
help system you access by selecting Help»Add-On
tHelp, where Add-On Heip |5 the name of the separate
help system for the add-on.

This help system links to Portable Document Format
(PDF) wersions of Lab¥IEW print documents, You must
have adobe Reader installed to wiew or search the PDF
versions of these manuals,

Refer ta the adobe Systerns Incorporated Web site to
download Adobe Reader,

& Note (Mac 08 X) National Instruments
recammends that you use Safari 1.3.2 or later
or Firefox 1.0.2 or later to view the LabUTEW
#elp. (Linux) National Instruments
recormmends that you use Mozilla 1.2 or later
or Firefox 1.0,2 or later to view the LabUTEW
Help.

For more information about this help system, refer to the
following topics:

m




Examples

3 NIExample Finder o] & =]
Browse

« LabVIEW includes
hundreds of example ViIs.

- Use NI Example Finder to =
browse and search

Information

ing and Documenting Applications

ntals
Input and Output

or LabbIEW 2009
or LabbIEW 2010

[ Teolkits and Modules

Installed examples.

.+ Select Help»Find e |
ExampleS in the menu. e

* Click the example buttons in LabVIEW Help topics.

@ Cpen EKEIFHD|E@ Find related examples




Controls Palette

« Contains the controls and
iIndicators you use to
create the front panel.

« Navigate the subpalettes
or use the Search button
to search the Controls
palette.

Cantrals
I Q Search I é% Custornize ™ l
|* Modern
1 M ¥ Taecl ¥
]ﬁ L ¥ [Fatn]
MNurmeric Boolean String & Path
M H }
[:1 =] Te. fhoxi)
Array, batrix.,  List.Table & Graph
"R Ld 4 4
[ 5,
(e i
Ring & Enum Caontaine Qo
o M on @ »
o oo
Wariant & Cl Decora tions Refrium
| Sikver
||| P Systern
||| ¥ Classic
[I» Exp

||| P Control Design & Simulation

[ MET & Activex

||| } Signal Processing

||| P Addons

||| ¥ User Contrals

||| Select a Control..,




Functions Palette

« Contains the VIs, functions,
and constants you use to
create the block diagram.

« Navigate the subpalettes or
use the Search button to
search the Functions
palette.

Functions

O‘ Search l é% Custamize ™ | :__|-|_|

|| ¥ Programming

¥ VT @
[R[1]?
b | e |,

O'= B &

DL

[ ¥ measurement Ifo

| ¥ Instrument Ifc

| '+ vision and Mation

[ ¥ mathematics

| v Signal Processing

| ¥ Data Cammunication

[ v cConnectivity

| v Control Design & Simulation

[ ¥ Express

[ v addans

[ v Favories

| v User Libraries

| selectavi.




Searching with Quick Drop

« Lets you quickly find
. {3 Quick Drop o e ==
COntrOIS, funCUOnS, VIS, [Random Murnber (0-1) |

Random Mumber {0-1

and Other |temS by name. TOMS Generate Randorn Data i

Periodic Random Moisesd [MLAALBase lvlib]

Per!odic Randam Noise PtBy P [NIl_PtbyPt.Iulib] .
° PreSS the <Ctr|_Space> Eiesrlcor:l;:ga:goorr:l\f;lmseWaueform.w[NI_MABase.Iuhb]
. . Continuous Randormsi
keys to dlsplay the QU'Ck Quasi Random.vi [MLAAL_SignalGeneration hiib]

Drop dialog box.

Shortouts... ] ’ Help




Global Search

Use the Searc
panel and b

pa

ettes, La

N bar in the top right of the front
ock diagram windows to search

OVIEW Help, and ni. com.

{3 Determine Warnings.si Block Diagra

File Edit “iew Project Operate

Tools  Window Help
et
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G. Selecting a Tool

Selecting a Tool
Block Diagram Clean-Up




Selecting a Tool

A tool is a special operating mode
of the mouse cursor.

Create, modify, and debug VIs
using the tools provided by
LabVIEW.

By default, LabVIEW automatically
selects tools based on the context
of the cursor.

If you need more control, use the
Tools palette to select a specific
tool.

Select View»Tools Palette to open the
Tools palette.

%F

Tools

III]."
D .

—|@T"¢f§=-

\




Wiring Tips

 Press <Ctrl-B> to delete broken wires.

« Right-click and select Clean Up Wire to
reroute the wire.

Mumeric




Wiring Tips — Clean Up Diagrgan

Use the Clean Up Diagram tool to reroute
multiple wires and objects and to improve
readability.

1. Select a section of your block diagram.

2. Click the Clean Up Diagram button on the block
diagram toolbar (or press <Ctrl-U>).




Cloning Items

« Clone an object in Windows using the following steps:
1. Select the Positioning tool.
2. Press the <Ctrl> key while clicking an object.
3. Drag the copy to new location.

Note: Avoid cutting and pasting objects as this can impact related items. For example, cutting
and pasting a block diagram terminal also moves the front panel object.




Setting options for the environment

In Tools»Options... dialog box you can customize settings for the
LabVIEW environment.

Suggested changes:
Front Panel page
Set Control Style for New Vls to Silver style
Block Diagram page
Uncheck Place front panel terminals as icons
Configure Block Diagram Cleanup to customize your block diagram




H. Dataflow




Dataflow

Murnber 1
[DELY " Result
}7>— y55L]
Muriber 2 |
50,00

[DELE

LabVIEW follows a dataflow model for running VIs.

« A node executes only when data are available at
all of its required input terminals.

« A node supplies data to the output terminals only
when the node finishes execution.




Dataflow — Quiz

What are the nodes In this fragment of
code?

Which node executes first?

input

greater?
IEEI-———[;?———————E;; .......... FTE ]
lﬁ-—(_




Dataflow — Quiz Answer

There are two nodes: ,square” and
,2greater than”?” functions.

Square executes first.

input

greater?
IEEI-———[;?———————E;; .......... FTE ]
15-—(_




Dataflow — Quiz

Which node executes first?

a) Add %hf ! Resulk 1
- FDBL |
b) Subtract —— ]
c) Random Number [DBL
Y Divide Mumber 3 Sine
- mber :
e) Sine el . F';._:%;ml:z
Mumber 4

[DELF




Dataflow — Quiz Answer

No single correct answer.

Which node executes first? Mumber 1
a) Add - Possibly (oL s B S
b) Subtract — Mumber 2

Definitely not [DBLE
c) Random Number —

Possibly Murrber 3 Sine_ ook 2
d) Divide — Possibly LI i (]
e) Sine — Definitely not Mumber 4
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|. Building a Simple VI




Building a Simple VI
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Acquire Express VIs

« DAQ Assistant Express VI

« Instrument I/O Assistant Express VI

« Simulate Signal Express VI
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« Read from Measurement File Express VI




Analyze Express Vis

« Amplitude and Level
Measurements Express VI
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« Statistics Express VI

el

« Spectral Measurements Express !

sl

- Tone Measurements Express VI

El

« Filter Express VI




Present Express VIs and Indicators

|
&

« Display Message Express VI

Play Waveform Express VI
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- Report Express Vi

« Write to Measurement
File Express VI

R EAJRe )2

DIAdem Report Express VI




Building and Running a VI

1. Place Express VI on the block diagram.
2. Configure the dialog box that opens.

3. Wire Express VIs together.

4. Save and run the VI.

The Run button appears broken when the
VI you are creating or editing contains
errors.
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