Currenty doing: Code duplication fix
- Same decompressTrack() function present in both old and new decoding
- decompressTrackStore() present both in old and new decoding
- In the old one creates a ClusterNative object and stores in a vector using emplace_back
- In the new one stores the ClusterNative object using plain array + counter
- Try to remove old decompressTrack()
- Use variadic templates on new decompressTrack() function
- Move decompressTrackStore() with vectors in new code
- Depending on the unpacked template, the correct decompressTrackStore() is called
Still to do:
- Update standalone benchmark to use new decoding with --compressionStat
- Check pp decoding performance (was a bit lower than expected)