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ELMAS – GETTING STARTED 

Starting an analysis project with ELMAS: 

a) Launch ELMAS 4.7 from desktop installation or by using Java web start from Ramentor 
Extranet (https://extranet.ramentor.com/elmas/). More details about launching the 
software from document: ‘ELMAS 4.7 – Information and Requirements.pdf’ 

b) For empty ELMAS project the startup tab is shown. The modeling is started by selecting a 
suitable modeling method and by defining the studied entity. To solve the Pumping unit 
example we use Fault tree model and stochastic simulation. 

 

c) Select Fault Tree graph tab type and press Create new graph tab. 

d) Define the studied system or event (Pumping unit fault) by using the fields (ID, Name and 
Description) of the opened Edit node dialog. You can also add notes, node color and 
attachments if needed. Press OK to save edited data and to close the Edit node dialog. 

e) A Fault tree tab is created and the model with the defined node is shown. 

https://extranet.ramentor.com/elmas/
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1 PUMPING UNIT BASIC ANALYSIS 

1.1 Fault Tree Analysis – Create the Cause Structure 

a) Think up reasons that can cause the studied event. Try to think about as large entities as 
possible (immediate causes). For example consider functional failures of the system 
before thinking specific failure modes of sub systems or components.  

b) Add new (child) node for each of the previously considered causes. A child node is added 
by right-clicking a node of the model and selecting Add new child. 

 

c) Define the added cause by using the fields (ID, Name and Description) of the opened Edit 
node dialog. Press OK to save the edited data. The child node is added below the original. 

d) Continue building the fault tree model by repeating the previous steps until all the 
relevant causes are added to the model. The cause structure is now created. 
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1.2 Fault Tree Analysis – Define Logic Conditions 

e) Make sure that the logic conditions between the nodes of the cause structure are correct. 
Sometimes a single cause is enough to trigger the event (OR-logic), sometimes all the 
causes must exist simultaneously to make it happen (AND-logic). 

f) The logic condition is defined by double-clicking the upper node to open the Edit node 
dialog and selecting the Tree tab of the Relations page. Simple logic condition changes 
can also be made directly without opening the Edit node dialog by right-clicking the 
relation icon (under the node). 

g) A Pumping line can handle all of the process flow so the Pumping fails only if both 
Pumping lines are at fault state. This is modeled by selecting AND as the logic rule. 

h) After Power input failure the backup diesel generator is started. The 95 % probability to 
start can be modeled by adding a probability gate between the nodes ‘Power shortage’ 
and ‘Power input failure’. A new gate is added by selecting Add new gate as parent. 
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1.3 ELMAS – Save the Project with Version Management 

i) It is good practice to save the created fault tree model regularly. It is possible to 
overwrite the currently open version (File -> Save Project) or use different project file, 
title or version (File -> Save Project As…). 

 

j) Several models can be saved inside a project file (.epg). For each model a title and three-
level version numbering can be used. Information and notes relating to the project file 
and each separate version can be added by using the text fields shown at Save As dialog. 
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1.4 Fault Tree Analysis  – Define Failure and Repair for Root Nodes 

k) The behavior of each gate is defined by the child nodes and the logic of the gate. The 
behavior of each root is modelled separately by defining the failure and repair times. The 
definition is made at the Failure and Repair pages of the Edit node dialog. 

l) There are several ways to define the failure time of a root depending on the available 
input data. The definition can be made based on history data or by directly estimating 
parameters related to the failure. The available methods shown in the Time to failure 
drop-down menu can be selected from Options -> Tasks -> OK. Method Estimate: Mean 
time to failure. The MTTF is defined and the failure distribution is created based on it. 

 

m) Similarly with the failure definition there are several ways to define the repair time. With 
method Estimate: Mean duration of repair the MTTR is defined and the repair distribution 
is created based on it. In addition to the repair time from the Resources tab of the same 
page the needed personnel and direct repair costs can be defined. 
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1.5 ELMAS – Table Summary Tool for Fast Data Edit 

n) Table summary tool is opened by selecting Tools -> Summary: Table from the menu bar. 

o) The shown data fields can be selected from the Properties tab by pressing Edit selections. 
Fields are included to the table by selecting them from the editor data fields tree 
(multiple selection with Ctrl) and pressing Select. The fields are deleted by selecting them 
again and pressing Remove selection. 

p) For definition of failure and repair times only root nodes can be selected to be shown. 

 

q) The Table tab shows the selected data fields of the selected nodes. Also copy-paste from 
for example Excel is possible. The edited changes are saved by pressing OK. 
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1.6 Fault Tree Analysis – Simulation 

r) The Simulation Tool is launched by selecting Tools -> Analysis: Simulation from menu bar. 

s) Studied time period (10 years) is simulated Simulation rounds (1000) times. After pressing 
Start simulation the simulation results pages will be soon available to show calculated 
result values and distributions. 

  

NOTE: Static seed 1424157511805 is used in this solution (Tools->Options->Tools-> Random seed) 

1A) What is the availability of the pumping unit?  

Answer for the first question can be found from page Basic and tab Availability.  

Answer: Availability of the Pumping unit is 99.91 %. 
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1B) How many failures will there occur during a 10-year period (mean and 90 % confidence)? 

Answer for the question can be found from page Basic and tab Studied period.  

Answer: Mean number of failures is 7.27. With 90% confidence at least 3 and at most 12 failures. 

 

1.7 Fault Tree Analysis – Define Risks Data 

t) Each risk data type has input fields which can be edited from Tools -> Options -> Risks. 
After editing press OK and select Close all tools and change now. 
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u) The costs that affect the risks can be added from Risks page. There are own tabs for 
different cost types. 

 

v) Risk data can also be added by using the table summary tool (Tools -> Summary: Table). 

1C) What is the economic risk during a 10-year period when the costs are as follows? 

Open the simulation tool and simulate again. Economic risks are shown at result tab Risks. 

Answer: Economic risk caused by failures is 290 000 €. 

  

NOTE: This result is the mean value of expected costs. Also much higher cost caused by failures 
is possible. With 95 % confidence the cost is less than 700 000 € and also cost over 1 000 000 € is 
possible. Similarly the real costs can be different than the expected mean value given in the 
following answers. 

1.8 ELMAS – Save the Basic Analysis Version 

w) Please remember to save the changes regularly. Because only improvements are made 
after chapter 1.3 the previous version can be overwritten. Select: File -> Save Project. 
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2 PUMPING UNIT SCENARIO ANALYSIS 

2.1 ELMAS – Drag and Drop, Move/Link/Copy and Paste, Delete 

a) Scenario analysis requires changes to the model. There can be several ways to model the 
same scenario. One solution to model that a control valve can be replaced without 
shutting down the whole system is to move the Control valve fault nodes under the 
Pumping line fault nodes. 

b) Move can be made with simple drag and drop by dragging a node to its new parent node. 

c) If the dragging is made with Shift pressed, the node is linked to new location without 
removing it from the original location. If the dragging is made with Ctrl pressed, a copy of 
the dragged node is created to the new location. 

d) Move/Link/Copy can be made also by selecting the operation by right-clicking a node. The 
operation is finished by right-clicking the destination node and selecting Paste. 

  

e) A node can be deleted by right-clicking the node and selecting Delete node. 
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2.2 Fault Tree Analysis – Define Investment Costs 

f) The input fields of risk data type Other costs can be edited from Tools -> Options -> Risks. 
You may replace Investments as the Risk title with a more suitable title that is used in 
Edit node dialog and simulation results. After editing press OK and select Close all tools 
and change now. 

 

g) The investment costs are defined from Other costs tab of Risks page. The investment cost 
is made at the beginning so the start time should be 0. When an interval is not defined the 
cost is made only once. 

 

2A) Would it be profitable to add hand valves before control valves? 

New simulation reveals the economic risk of scenario 2A. 

Answer: After the change the 10-year life-cycle costs (investment cost added by economic risk 
caused by failures) will be 135 000 e. The investment would be very profitable. 
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2.3 ELMAS – Save the Scenario 2A) Version 

h) Select for example File -> Save Project As and give a new version title Scenario 2A. 

2.4 Modification Steps – Scenario with Separate Power Inputs 

i) Move the ‘Power Shortage’ subtree under one ‘Pumping line’ node (Move & Paste). 

j) Take a copy of the ‘Power Shortage’ subtree and paste it under another ‘Pumping line’ 
node (Copy & Paste). 

 

k) Delete the useless ‘Pumping fault’ node below the ‘Pumping unit fault’ (Delete node). 

l) Change the gate type of ‘Pumping unit fault’ (Edit node -> Relations -> Gate type: AND). 

m) Add 30 000 € investment cost to ‘Pumping unit fault’ node (Edit node -> Risks -> Other 
costs). NOTE: If you add two investment costs with exactly the same start time remember 
to uncheck the box ‘Only first cost if overlap’. 
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2B) Would it also be profitable to create a separate power input for both pumping lines? 

New simulation reveals the economic risk of scenario 2B. 

Answer: After the change the 10-year life-cycle costs will be 85 000 €. 

NOTE: With 95 % confidence the LCC will be less than 110 000 e, so not only the mean but also 
the risk of very large cost gets significantly lower. 

2.5 ELMAS – Save the Scenario 2B) Version 

n) Select for example File -> Save Project As and give a new version title Scenario 2B. 

2.6 Modification Steps – Scenario with a Better Pump 

o) Update the failure time estimation of ‘Pump 1 fault’ node (Edit node -> Failure). The 
repair time estimation doesn’t change. 

p) Update the spare part costs of ‘Pump 1 fault’ node (Edit node -> Risks -> Repair start). 

q) Add 5 000 € investment cost to ‘Pumping unit fault’ node (Edit node -> Risks -> Other 
costs). 

 

2C) Would it also be profitable to change the other pump for a better one? 

New simulation reveals the economic risk of scenario 2C. 

Answer: After the change the 10-year life-cycle costs will be over 90 000 €. Downtime costs are 
already so low that there isn’t enough saving potential to make this pump investment profitable. 

2.7 ELMAS – Save the Scenario 2C) Version 

Select for example File -> Save Project As and give a new version title Scenario 2C. 
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3 PUMPING UNIT ADVANCED ANALYSIS 

3.1 ELMAS – Undo and Load Previous Version 

a) It is possible to take back the undesired changes by selecting Edit -> Undo. 

 

b) With regular saving and careful project versioning it is easy to open previous situations 
whenever needed. Saved project version can be opened from Files -> Open project. 

  

3.2 Fault Tree Analysis – Define Resource Groups and Maintenance Actions 

c) Define resource groups from: Options -> Maintenance -> Selections -> Resource selection. 

d) The resource group specific costs are added from: Node editor -> Repair -> Resources 
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e) Maintenance actions can be added at Node editor -> Maintenance. 

 

f) NOTE: Effect factor is used to define how the created maintenance action affects the 
failure behavior of the node. Value 1.0 means that the maintenance action has no effect. 
With a value of 0.5 the failure frequency of the part would become half of the original 
which means that the time between failures would double. 

3A) What is 10 years LCC* with resource costs and maintenance actions included? 

New simulation reveals the economic risk of scenario 3A. 

 

Answer: With resources and maintenance actions included in the situation 2B) the Life-cycle 
cost (investment costs and total operation costs) will be 150 000 €. 

3.3 ELMAS – Save the Scenario 3A) Version 

Select for example File -> Save Project As and give a new version title Scenario 3A. 
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3.4 Fault Tree Analysis – Overlapping of Break and Downtime costs 

g) The break and downtime costs are not cumulated in ELMAS if both the parent node and its 
child node are in a situation (failed) in which costs should be added. The costs of child 
nodes are ignored and only the cost of the parent node is added. 

h) This behavior is useful only when the logic condition is other than OR. With OR gate the 
break and downtime cost should be added to only one tree level. If the cost is defined for 
an OR gate, the costs of the child nodes are never added because an OR gate always 
occurs when any of the child nodes are failed. The cost of an OR gate is overlapped with 
the costs of the child nodes and only the cost of an OR gate is added. 

i) The repair start and repair time costs are handled in opposite way. They are always 
cumulated and never ignored because of overlapping. 

j) By adding a downtime cost (750 €) to both ‘Pumping line fault’ nodes the 25% production 
loss can be modelled. Because of the overlapping behavior of ELMAS the changes are not 
needed to be made for the downtime loss of the Pumping unit fault node. 

  

k) NOTE: Definition of delays of costs can be enabled from Tools -> Options -> Risks. With 
delays the overlapping property of downtime costs can be useful also with OR gates. 
(Delays of costs are not needed in this example) 

l) NOTE: By default only static cost definition is used in ELMAS. Stochastic input methods can 
also be made available from Tools -> Options -> Risks. The available input types are 
selected separately for each cost type. (Other than static costs are not needed in this 
example) 

3B) LCC if single pumping line is capable only for 75 % of the needed throughput? 

New simulation reveals the economic risk of scenario 3B. 

Answer: With the limitation of a single pumping line throughput the economic risk caused by 
production loss will get 190 000 € higher and the LCC will be 340 000 €. 

3.5 ELMAS – Save the Scenario 3B) Version 

Select for example File -> Save Project As and give a new version title Scenario 3B. 
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3.6 Fault Tree Analysis – Condition, Delay, Duration and Probability Gates 

m) The condition gate can be selected from Node editor -> Relations. In basic situation it 
defines the probability rule between the child node and the gate. When the child node is 
failed the condition gate will be failed at a given probability. 

n) Delay can be included in the condition gate by checking the Use failure time (delay). A 
delay is defined in the Failure page similarly as with root node failure. When a child node 
is failed the gate will be failed after the defined delay. 

  

o) Duration can be defined for the condition gate by checking Use repair time (duration). 
The duration is defined in Repair page similarly with root node repair. When a gate node 
fails the duration of the failure of the child node does not affect the duration of the 
failure of the gate. (Repair gates are not needed in this example) 

p) The probability gate is similar with condition gate that has only probability defined (no 
delay nor duration). The difference is that when a probability gate is linked under several 
nodes the probability can be defined for each of them separately. The linked 
consequences are exclusive. A probability gate is shown in the analysis results as many 
times as it has been linked. 
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3.7 Modification Steps – Scenario with Backup Generator Running Failures 
Considered 

q) Add new node “Diesel generator running failure” (ID 3) under “Power shortage” node. 

r) Use probability gate to separate event chains “Backup generator fails to start” and 
“Backup generator starts”.  

 

s) Rename the node “Power input failure and backup diesel generator fails to start” (ID 13) 
as “Power input failure and backup diesel generator”. 

t) Define the node (ID 13) consequence titles and probability weights. For the parent “Power 
shortage” use Consequence title “fails to start” and probability 0.05. For the parent 
“Diesel generator running failure causes power shortage” use Consequence title “starts” 
and probability 0.95.   

u) Use gate type Condition (Delay/Duration) to model “Diesel generator running failure 
causes power shortage” and select Use failure time (delay). 

v) Add MTTF estimation for backup diesel generator running failures. 

 

w) Set MTTR-field empty (no repair), because power input is repaired always. 

x) Repeat the same steps to other Pumping line. 



 
ELMAS 4 – Pumping Unit Example Solution 26.2.2016 

 
21/21 

 
 

 

 

 

3C) Will the results change if backup generator failures after start are considered? 

New simulation reveals the economic risk of scenario 3C. 

 

Answer: Compared to situation 3B) the backup generators running failures cause 10 000 € extra 
economic risk. LCC of the pumping unit will be 350 000 €. 

3.8 ELMAS – Save the Scenario 3C) Version 

Select for example File -> Save Project As and give a new version title Scenario 3C. 


