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Study of the characteristic X-ray spectra 
using silicon hybrid pixel detector 

Abstract 
This experiment is designed to introduce a pixelated silicon state-of-the-art X-rays detection system 
developed at CERN as a spin-off development of the Large Hadron Collider (LHC). A basic 
understanding of semiconductor pixel detectors will be given by calibrating the detector with known 
X-ray sources and measuring spectrum from an 241Am gamma source. A variety of software tools will 
be used for data acquisition, detector calibration and data analysis. 
 

Objectives 
 Understand X-ray detection mechanisms in pixellated silicon detectors; 

 Measure X-ray energy spectra from various x-ray sources; 

 Gain practical skills in data acquisition using specialised program Pixelman; 

 Practice data mining skills. 
 

Caution 
This experiment involves the use of an X-rays source. Improper use could result in long 
term health consequences. The source should be handled with care. The Timepix 
detection system is fragile and very expensive. Please handle with care. 
 

General recommendations 
Use folder “C:\TimepixLab\YourName\” to store any files. There are questions in the script 
highlighted with  sign. These are guide questions for discussion. 
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TimePix detector 
The hybrid pixel detector is one of several types of instrumentation currently available for X-ray 
precision measurement. What other types of detectors do you know? It comprises of a detection 
medium and readout electronics manufactured in different fabrication processes. Both parts of the 
detection system have a matching matrix of electrodes which are brought into contact via a process 
called flip-chip bonding (see Figure 1). What other solid-state detectors apart from silicon are in use? 
The Timepix detector used in this experiment is a novel development by CERN (see Figure 2). It 
comprises of 256x256 pixels each of 55x55 µm2 that can operate in spectroscopic mode (Time-over-
Threshold mode, known as ToT mode), where energy information is obtained at the same time as 
the position of interactions. What other modes can this device run in? The data is read out by the 
plug & play USB interface using the Pixelman software. How does the ToT mode work? Discuss with 
the demonstrator. 

 
Figure 1 Hybrid pixel detector schematics 

 
Figure 2 Timepix detector 

? 
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Experimental procedures 

Experimental setup 
Figure 3 shows the diagram of the detection system used for this experiment. It consists of a various 
x-ray/gamma ray sources, (use the internet to find the energy of the x-ray lines of the sources during 
less busy times of the lab), a Timepix detector with USB interface and PC used for data acquisition. 
The USB interface has two connections. The LEMO cable provides DC bias to the silicon detector 
(+100V) from the USB interface. The USB cable powers the device and handles data acquisition. 
 

 
Figure 3 Characteristic X-rays spectra acquisition setup 

Setting up the detector 
Run Pixelman program from the Desktop. Two windows should pop up, Medipix Control and 
Preview. The first one is used to control the parameters of data acquisition and setting up the 
sensor, the latter displays data. The software is user friendly and most of the options are self- 
explanatory. 
Check that the bias on the detector is set correctly (Medipix Control → Options →Device Settings → 
Interface Specific Info tab). Check, that bias voltage is about 100 V (usually 94-98 V). Otherwise 
consult your demonstrator. Why do you need to bias a silicon detector? 
Check that the ToT clocking frequency is set to 40 or 48 MHz (Medipix Control → Options →Device 
Settings → Interface Specific Info tab, set TimePix clock value to 2). 
 

Threshold equalisation 
The Timepix sensor operates in a “noise-free” mode. The chip removes the electronic noise in the 
silicon detector system by setting an appropriate threshold (called THL in Pixelman), below which, 
the signal induced in the pixel is disregarded. The threshold needs to be adjusted per pixel with a per 
pixel threshold adjustment bit. Think, why would one need to equalise thresholds in different pixels? 
Each pixel in the chip responds in a slightly different way to incident radiation due to transistor 
fabrication mismatches and non-uniformities of the detector. In order to obtain better and more 
uniform response, the narrowest possible distribution of pixel threshold levels across the chip has to 
be found. The procedure for threshold equalisation is described below. It is recommended to 
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perform this once a day to ensure uniform response of the chip. Think, what could happen on 
another day that affects the performance of the detector? 
Medipix Control → File → Set Mode → Medipix 
Medipix Control → File → Reset Pixel Cfg. → All Bits 
Medipix Control → Tools → Threshold Equalization 
A window similar to the one in Figure 4 will be displayed. Make sure that the parameter values on 
the left hand side of the window are as indicated. 
Press Start. The plot on the right hand side should look similar to the one displayed on completion. If 
the distributions do not have Gaussian-like shape, it could be due to too much ambient light is 
incident on the detector. Cover it with black tape etc.  
This procedure takes about 10 minutes. Discuss with each other and the demonstrator what is 
happening during this procedure. Look at the results window and try and understand what it is 
showing you. 
 

 
Figure 4 Threshold Equalization of the chip 

 
Medipix Control → Tools → DAC Control Panel (see Figure 5) 
The THL value is ambient temperature dependent, but should be around 350-380 ADC. What do ADC 
and DAC stand for? Set THL to about 20 units below the indicated value in Figure 5, e. g. if the 
displayed value is 363 ADC, set ~343 ADC.  
Note that a lower THL value here implies a higher 
threshold valve. 
Close DAC Control Panel window. 
Close Threshold Equalization window. 
 
In the Medipix Control window set  
Acquisition type Integral 
Acquisition count 200 

Acquisition time 0.1 Figure 5 DAC control panel 

? 

? 

? 



 

Silicon Detectors 
Laboratory     

TimePix X-rays              
 

2017 

 

R. Bates, L. Eklund, I. Nasteva  Cuba, November 2017 
 Page 5 

Press Start to acquire data. In the Preview for Medipix Control window set Max Level 1. Some pixels 
will be shown in red, indicating an excessive (> 100) number of counts. These are to be excluded 
from further data acquisition.  
If there are an excessive number of red pixels set the THL DAC level 5 lower.  
Right click on the image area and select Mask... from the menu, enter 1 and press OK. These pixels 
now should be displayed in blue. 
The setup is now ready for data acquisition. Can noise pixels appear in the future? Why? 

Time over Threshold (ToT) x-ray energy spectra 

Data acquisition  
A photon of specific energy generates a number of electron – hole pairs in the detector. What 
energy is required to generate an electron-hole pair in silicon for ionisation from high energy 
photons/particles? These are collected by the pixels and converted into digital numbers. There is a 
relationship between incident photon energy and corresponding ADC value for a given detector. 
In order to establish this relationship, spectra of known X-ray sources must be recorded. In this 

experiment characteristic photons from a range of X-ray/gamma sources (Am-241 and, Ba-133), an 

electron source (Cs-137) and a mixed alpha particle source will be used. 
There is limited time for this laboratory and it is not expected that a full energy calibration will be 
possible. Data will be collected over the session to build up a more detailed graph. You results of X-
ray energy and ToT value should be added to the Calibration Graph spread sheet on the desktop. 
It is important to look at the images collected in the Pixelman Preview window and at the spectra 
produced in the analysis section. 
 
Place the source on top of the detector. 
In the Pixelman software follow this procedure. 
 
Medipix Control → File → Set Mode → Time Over 
Threshold 
Set Acquisition Control parameters as shown in 
Figure 6. 
Acq. type Frames 
Acq. count 2000 
Acq. time 0.1 
Binary matrix 

√ Single file 

√ File output 
The file output should correspond to each target 
element to be recorded, e.g. for Ba target the path 
should look like  
“C:\TimepixLab\yourFolderName\Ba_.tpx” 
Press start. In the Preview window interactions of 
X-rays with the silicon sensor will be displayed and recorded. There are several options in the 
window available for better output data representation. Play around and figure out what they do. 

Acquire data for at least one of the following sources: Am-241, Ba-133; and also for Cs-137 and a 
mixed alpha particle source. 

Figure 6 Medipix Control Panel 

? 
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Why does the image on the Preview screen look so different for the Cs-137 source and the 
alpha source? 

Data analysis  
Interaction of X-ray photons in the sensor is recorded in the form of digital units (ADC). These are 
converted into the incident photon energy utilising a calibration curve. Moreover, since the electron-
hole cloud generated is of a finite size, sometimes interactions are recorded by several pixels 
simultaneously. The spread of charge between adjacent pixels has to be corrected in order to obtain 
the correct spectrum (this is called clustering).  
 
A root script will be used to perform the data analysis from Pixelman.  
Open root by clicking on the desktop icon. 
Load the cluster analysis code (.L clusterAna.cpp) 
To run the code read TimePix with the following input variable: your data file, number of events, 
debug: 
readTimePix(“../TimepixLab/yourFolderName/Ba_.tpx”, 2000, false) 
 
The code returns to screen the number of clusters found per frame. 
When the analysis is finished a canvas appears that contains three graphs, the ToT (energy) spectra 
obtained for single pixel clusters, the energy spectra obtained for multi-pixel clusters and the cluster 
size distribution. 
 
Think about the shape of the different spectra. Make a note of the peak(s) from the spectra and 
record this against the X-ray energy to form a calibration graph.  Are there any peaks present in the 
multi-pixel clusters that are absent from the single pixel clusters, if so why? Why does the spectrum 
from the Cs-137 look so different to those from the other sources? Discuss you results among each 
other and with one of the demonstrators. 
 

Additional literature  
1. Llopart X, Ballabriga R, Campbell M, Tlustos L, Wong W. Timepix, a 65k programmable pixel 

readout chip for arrival time, energy and/or photon counting measurements. NIMA. 2007, 
581(1-2):485-494. DOI: 10.1016/j.nima.2007.08.079 

2. Jakubek J, Cejnarova A, Holy T, et al. Pixel detectors for imaging with heavy charged 
particles. NIMA 2008, 591(1):155-158. DOI: 10.1016/j.nima.2008.03.091 

3. Jakubek J. Semiconductor pixel detectors and their applications in life sciences. Journal of 
Instrumentation. 2009;4(03):P03013-P03013. DOI: 10.1088/1748-0221/4/03/P03013  

4. Jakubek J. Data processing and image reconstruction methods for pixel detectors, NIMA. 
2007, 576(1):223-234. DOI: 10.1016/j.nima.2007.01.157 

5. Glenn K. Knoll, Radiation Detection and Measurement, 3rd edition, John Wiley and Sons, 
1999, Chapter 2 (III), Chapter 11. 

6. Frank H. Attix and William C. Roesch (1968), Radiation Dosimetry, 2nd ed., Academic Press, 
95.  

7. Max Born (1989), Atomic Physics, 8th ed., New York: Dover Publications, 126-127. 
8. G. P. Harnwell and J. J. Livingood (1933), Experimental Atomic Physics, 1st ed., MaGraw-Hill 

Book company, 363-365. 
9. J. C. Willmott (1975), Atomic Physics, John Wiley & Sons Ltd., 324-328. 
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Other relevant sources of information 
1. Timepix chip http://www.cern.ch/MEDIPIX 
2. Pixelman software http://aladdin.utef.cvut.cz/ofat/others/Pixelman/Pixelman.html 
3. Periodic table elements fluorescence X-ray energies http://xdb.lbl.gov/ 

http://www.cern.ch/MEDIPIX
http://aladdin.utef.cvut.cz/ofat/others/Pixelman/Pixelman.html
http://xdb.lbl.gov/
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